You need a Java aware browser to run this applet

v2.2 - Client Applet 

Warning: closing this window will
terminate your applet session

Fifth Third FX online trading platform updates

On September 12, 2016 Fifth Third’s FX online trading platform will be upgraded to improve the user interface and address compatibility issues experienced by some customers.

Action Required:

To access the platform on September 12th your computer will need to be running Java versions 1.7 or 1.8 as well as Internet Explorer 11. You will not need to upgrade Java if you are currently running version 1.7. Google Chrome is not supported at this time. To mitigate the risk of any service disruptions please make sure you have a supporting Java version and internet browser by September 12th. Please note that updating Java versions and your internet browser prior to September 12th may disable your current access to online trading. In short, your upgrade must occur on September 10th or 11th to ensure no disruption of service.

Should you require further assistance, please call the trading desk during business hours at 1-800-542-1822.